summaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@flameeyes.com>2020-10-04 20:51:50 +0200
committerDiego Elio Pettenò <flameeyes@flameeyes.com>2020-10-04 21:22:14 +0200
commit2da7720c565f560816a16462eeb6134e9741ee64 (patch)
tree2a621f8278fd3a41f3220d856fbe15379d0f32af /pyproject.toml
parentAdd missing py.typed files to package. (diff)
downloadfreestyle-hid-2da7720c565f560816a16462eeb6134e9741ee64.tar
freestyle-hid-2da7720c565f560816a16462eeb6134e9741ee64.tar.gz
freestyle-hid-2da7720c565f560816a16462eeb6134e9741ee64.tar.bz2
freestyle-hid-2da7720c565f560816a16462eeb6134e9741ee64.tar.lz
freestyle-hid-2da7720c565f560816a16462eeb6134e9741ee64.tar.xz
freestyle-hid-2da7720c565f560816a16462eeb6134e9741ee64.tar.zst
freestyle-hid-2da7720c565f560816a16462eeb6134e9741ee64.zip
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml11
1 files changed, 11 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index e6eedfe..a062cb5 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -42,3 +42,14 @@ known_first_party = ['glucometerutils']
known_third_party = ['construct', 'hidapi', 'pyscsi', 'serial', 'usbmon']
[tool.setuptools_scm]
+
+[tool.pytest.ini_options]
+addopts = "--color=yes --ignore=setup.py -ra"
+timeout = 120
+norecursedirs = [
+ '.env',
+ '.git',
+ 'dist',
+ 'build',
+ 'venv',
+]